DevioLabавтоматичне керування капіталом
ПРАЦЮЄ 24/7
КРИПТОВАЛЮТИ · АКЦІЇ · 10 БІРЖ

Портфель, який керується автоматично

DevioLab підбирає стратегії, відстежує ринки та автоматизує купівлю і продаж активів. Кількість доступних криптовалют, акцій і торгових можливостей зростає щодня.

10підключених біржCrypto + Stocksв одному портфелі24/7автоматичний контроль

Реалізація способів вирішення імен

Інформація про навчальний заклад

ВУЗ:
Національний університет Львівська політехніка
Інститут:
Інститут комп’ютерних наук та інформаційних технологій
Факультет:
Комп’ютерні науки
Кафедра:
Кафедра програмного забезпечення

Інформація про роботу

Рік:
2009
Тип роботи:
Звіт
Предмет:
Мережеві операційні системи
Група:
ІБ – 44
Коротко про документ

Про що ця робота

У звіті з лабораторної роботи досліджено способи вирішення імен у мережевих операційних системах. Описано принципи роботи служб NetBIOS та DNS, а також виконано налаштування DNS-серверів.

У роботі розглядаються

  • Мережеві операційні системи
  • Вирішення імен
  • Служба DNS
  • Протокол NetBIOS
  • IP-адресація
  • Доменні імена
  • Налаштування DNS-сервера

Зміст і розділи

  1. Короткі теоретичні відомості
  2. Завдання
  3. Хід роботи
  4. Висновок
Для кого:Студенти технічних спеціальностей вищих навчальних закладів
Викладачі:Тишик І. Я.

Ключові поняття

DNSNetBIOSIP-адресадоменне ім'язона DNSширокомовний запитMAC-адресаделегування домена

Частина тексту файла (без зображень, графіків і формул):

МІНІСТЕРСТВО ОСВІТИ І НАУКИ УКРАЇНИ НАЦІОНАЛЬНИЙ УНІВЕРСИТЕТ “ЛЬВІВСЬКА ПОЛІТЕХНІКА” ЗВІТ З ЛАБОРАТОРНОЇ РОБОТИ № 3 З КУРСУ: “ МЕРЕЖЕВІ ОПЕРАЦІЙНІ СИСТЕМИ ” НА ТЕМУ: “ РЕАЛІЗАЦІЯ СПОСОБІВ ВИРІШЕННЯ ІМЕН ” Львів 2009 Короткі теоретичні відомості В операційних системах, котрі початково розроблялися для локальних мереж, таких як Novell NetWare, Microsoft Windows або IBM OS/2, користовачі завжди працювали зі символьними іменами комп’ютерів. Оскільки локальні мережі складалися з невеликого числа комп’ютерів, застосовувалися для їх ідентифікації так звані “плоскі” імена, які складалися з послідовності символів, не розділених на частини (наприклад: NW_1, mail2, WS212_1, і т.д). Для встановлення відповідності між символьними іменами комп’ютерів і MAC-адресами у цих операційних системах застосовувався механізм широкомовних запитів. Так, широкомовний спосіб вирішення імен реалізований у протоколі NetBIOS (Network Basic Input/Output System), на якому було побудовано більшість локальних ОС. Для стеку TCP/IP, розрахованому в загальному випадку на роботу у великих територіально розподілених мережах, подібний підхід виявився неефективним (хоча, з метою вирішення проблеми об’єднання в один цих двох протоколів, Internet Engineering Task Force (IETF) випустила серію стандартизуючих документів під назвою RFC 1001 і 1102, які описують роботу NetBIOS над TCP/IP. З тих пір пакет цих документів є відомий під іменем NetBIOS над TCP/IP або NBT (У цьому випадку існує метод прив’язки імені NetBIOS до конкретної IP-адреси. Цей процес називається визначенням імені і може вирішуватися двома способами: а) кожен комп’ютер повинен передати запросившому свою IP-адресу, після одержання широкомовного запиту на своє NetBIOS ім’я; б) використовувати NBNS (NetBIOS Name Server) для розпізнавання імен NetBIOS в IP-адрес). У процесі розростання INTERNET і, відповідно, збільшення кількості вузлів виникла необхідність масштабованого рішення для вирішення імен. Таким рішенням стала централізована служба DNS (Domain Name System – Система Доменних Імен), яка базується на розподіленній базі відображення “доменне ім’я – IP-адреса”. Служба DNS використовує у своїй роботі DNS-сервери і DNS-клієнти. DNS-сервери підтримують розподільну базу відображень, а DNS-клієнти звертаються до серверів зі запитами щодо вирішення доменного імені в IP-адресу. У доменній системі імен розрізняють короткі імена, відносні імена і повні доменні імена. Коротке ім’я – це ім’я кінцевого вузла мережі (хоста чи порта маршрутизатора). Відносне ім’я – це складене ім’я, яке починається з деякого рівня ієрархії, но не найвищого. Повне доменне ім’я включає складові усіх рівнів їєрархії. DNS - Система Доменних Імен [RFC1034, RFC1035]. Доменне ім'я - це ім'я, використовуване для адресації комп'ютерів і ресурсів в Internet за допомогою звернення до глобальної системи доменних імен (DNS). Доменне ім'я складається з компонентів, розділених знаками "." (наприклад, www.lviv.ukrtelecom.ua). Домен - це автоматизована система, що складається з доменного імені, всіх його піддоменів і сукупності організаційного, технічного, програмного, документального і інших видів забезпечення, призначених для підтримки її функціонування. Рівень домена - це кількість компонентів в доменному імені, розділених знаками ".". Домен першого рівня .ua містить в собі всі делеговані в нім домени другого рівня - com.ua, net.ua, ukrtelecom.ua і ін. - і всі їх піддомени. Делегування домена - це виконання адміністратором охоплюючого домена дій по включенню домена, що делегується, в глобальну систему доменних імен, унаслідок яких регистрант домена, що делегується, дістає можливість використовувати його для адресації в мережі Internet. Реєстрація доменного імені - внесення до центральної офіційної публічно доступну базу даних інформації про факт і суб'єкта делегування домена. Адміністратор домена - це особа, що володіє правами по використанню доменного імені (зокрема, винятковим правом делегування піддоменів), а також певними обов'язками. Реєстратор - це особа, що надає регістрантам послуги, необхідні для делегування їм домена і підтримки його функціонування. Зона - це частина дерева, за яку відповідає той або інший DNS-сервер. Наприклад, в домені ukrtel.net є піддомен dc. Адміністрація DNS-сервера домена ukrtel.net делегувала домен donetsk серверам соотвествующего підрозділу. Таким чином, в домені ukrtel.net утворилися 2 зони: одна зона, співпадаюча з доменам dc.ukrtel.net і друга зона, що складається з частини домена ukrtel, що залишилася.net. Пряма Зона - зона, що містить дані об відображенні імен в адреси вузлів, точки прийому пошти і ін. Зворотна Зона - зона, що містить дані, використовувані для відображення адреси в ім'я. Сервер DNS - машина або програма, що працює відповідно до DNS протоколами, здатний давати відповіді на запити. Відповіді можуть містити інформацію, відому даному серверу, або інформацію, отриману від іншого сервера. Автори[ім’я автора приховано] Первинний сервер - авторитетний сервер, для якого інформація про зону описана локально. Іноді його ще називають майстер-сервер. Вторинний сервер - авторитетний сервер, який отримує інформацію про зону від Первинного Сервера через механізм пересилки зони (zone transfer). Іноді його називають підлеглий сервер. Резолвер (разрешитель) - клієнт системи DNS, який за допомогою DNS протоколів шукає інформацію, що міститься в зоні. Завдання Здійснити централізоване вирішення «символьне ім’я –ІР-адреса» для вузлів об’єднаної мережі вашої спроектованої корпоративної мережі. Забезпечити доступ до INTERNET користувачів вашої мережі. Забезпечити послугу WWW лише для «корпоративних» користувачів вашої мережі. В-6 Хід роботи   Висновок: виконавши дану лабораторну роботі я дізналася про призначення DNS-сервeрів та навчилася налаштовувати їхню роботу.
Допоможи студентському архіву

Ми допомогли тобі — допоможи наступному студенту

Файл ще не обрано

Оголошення від адміністратора

Антиботан аватар за замовчуванням

Подякувати Студентському архіву довільною сумою

Admin

26.02.2023 12:38

Дякуємо, що користуєтесь нашим архівом!